Clicky

FBI and CISA warn of state hackers exploiting critical Zoho bug

FBI and CISA warn of state hackers exploiting critical Zoho bug

Image: Samueljjohn (CC BY-SA 4.0)

The FBI, CISA, and the Coast Guard Cyber Command (CGCYBER) today warned that state-backed advanced persistent threat (APT) groups are actively exploiting a critical flaw in a Zoho single sign-on and password management solution since early August 2021.

Zoho’s customer list includes “three out of five Fortune 500 companies,” including Apple, Intel, Nike, PayPal, HBO, and many more.

The vulnerability tracked as CVE-2021-40539 was found in the Zoho ManageEngine ADSelfService Plus software, and it allows attackers to take over vulnerable systems following successful exploitation.

Attacks also target critical infrastructure orgs

This joint security advisory follows a previous warning issued by CISA last week, also alerting of CVE-2021-40539 in the wild attacks that could allow threat actors to execute malicious code remotely on compromised systems.

“The exploitation of ManageEngine ADSelfService Plus poses a serious risk to critical infrastructure companies, U.S.-cleared defense contractors, academic institutions, and other entities that use the software,” the joint advisory warns.

“Successful exploitation of the vulnerability allows an attacker to place webshells, which enable the adversary to conduct post-exploitation activities, such as compromising administrator credentials, conducting lateral movement, and exfiltrating registry hives and Active Directory files.”

In incidents where CVE-2021-40539 exploits have been used, attackers have been observed deploying a JavaServer Pages (JSP) web shell camouflaged as an x509 certificate.

This web shell is subsequently used for lateral movement via Windows Management Instrumentation (WMI) to access domain controllers and dump NTDS.dit and SECURITY/SYSTEM registry hives.

So far, APT groups behind these attacks have targeted an extensive array of sectors from academic institutions and defense contractors to critical infrastructure entities (e.g., transportation, IT, manufacturing, communications, logistics, and finance).

Mitigation measures

Zoho has released Zoho ManageEngine ADSelfService Plus build 6114, which patches the CVE-2021-40539 vulnerability on September 6.

In a subsequent security notification, the company added that it is “noticing indications of this vulnerability being exploited” in the wild.

FBI, CISA, and CGCYBER urge organizations to immediately apply the ADSelfService Plus build 6114 update and ensure the ADSelfService Plus is not directly accessible from the Internet.

“Additionally, FBI, CISA, and CGCYBER strongly recommend domain-wide password resets and double Kerberos Ticket Granting Ticket (TGT) password resets if any indication is found that the NTDS.dit file was compromised,” the agencies added.

Organizations that detect malicious activity associated with ManageEngineADSelfService Plus indicators of compromise are advised to immediately report it as an incident to CISA or the FBI.

Scroll to Top